php version (7.2.34) does not satisfy that requirement.

When i download the Laravel project from Github and setup project i run composer update its showing this types of error

Problem 1
- Root composer.json requires php ^7.3|^8.0 but your php version (7.2.34) does not satisfy that requirement.
Problem 2
- phpro/grumphp[v1.0.0, ..., v1.1.0] require php ^7.3 -> your php version (7.2.34) does not satisfy that requirement.
- phpro/grumphp[v1.2.0, ..., v1.3.1] require php ^7.3 || ^8.0 -> your php version (7.2.34) does not satisfy that requirement.
- Root composer.json requires phpro/grumphp ^1.0 -> satisfiable by phpro/grumphp[v1.0.0, ..., v1.3.1].

Let open editor and run below

composer install --ignore-platform-reqs

Thanks

Amit Kumar
Tagged : / / /

Leave a Reply